[Xcode] HighSierraでCocoaPodsが使えなくなった

使えなくなったというか、

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby: bad interpreter

とか出て使えない。まぁRubyが古いって言われてると思うんだけど、調べてみたらどうやら

sudo gem update --system

でアップデートさせると良いらしい。

で、早速podsのインストール(sudo gem install cocoapods)をしたら

ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions into the /usr/bin directory.

こんなんが出てインストールできない。パーミッション周りのエラー・・・で、また調べて見たら、

sudo gem install cocoapods -n /usr/local/bin

これでインストールしたら無事にできた模様。調子こいてOSアップデートしたツケか・・・